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Contact your Authorized Curtain Reseller or Service Provider to report problems 
and/or provide feedback. 

 

Additional help resources or updates will be available by emailing 
info@coworkshop.com  
 
Coworkshop Solutions Ltd. reserves the right to make changes to this document 
and to the product described herein without notice. The software described in 
this manual is furnished under the terms and conditions of the Curtain Software 
License Agreement and may be used or copied only in accordance with the terms 
of the agreement. 
 
For information about your legal rights concerning the use of the Curtain 
MonGuard, please refer to the Curtain Software License agreement.  
 
© 2002-2024 Coworkshop Solutions Ltd. All Rights Reserved. Curtain belongs to 
Coworkshop Solutions Ltd. All other brand names, product names, or trademarks 
belong to their respective holders.  
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1 - Introduction
1.1 - Challenges of Data Leakage through Computer's Screen

In everyday operations, users have access to and work on sensitive files.  However, it is difficult for 
companies to prevent users taking photo/video against computer's screen by using mobile phone when 
accessing sensitive information (e.g. personal information, CCTV footage and other sensitive data). Due to 
COVID-19, more and more people work from home. Companies have to allow users to download data to 
notebook and access the data at home or allow them to connect to company's network through VPN. It 
increases the difficulty of preventing data leak through screen. 

Online meeting is another security challenge. When people need to show something to meeting 
participants (e.g. contracts, designs and even training materials) during online meeting, how to protect the 
information shown to participants? Although we cannot prevent people to take photo/video against 
computer's screen, at least we should be able to trace the source of data leakage.

1.2 - What is the purpose of Curtain MonGuard?

Curtain MonGuard is a solution for displaying screen watermarks that administrators can enable on users' 
computers. This screen watermark can display various user information, such as the computer name, username, 
and IP address. The purpose of this watermark is to effectively grab the user's attention and serve as a reminder 
before they take a screenshot or photograph the screen to share the information with others.

The key benefit of Curtain MonGuard is that it encourages users to "think before sharing" sensitive information. If 
the content being shared contains confidential company data, the watermark can help trace the source of the 
leaked information back to the user responsible. This allows organizations to hold users accountable and mitigate 
the consequences of data breaches or unauthorized information sharing.

1.3 - Components of Curtain MonGuard

There are 2 basic components of Curtain MonGuard:
Curtain Lite Client

Curtain Lite Admin (for the machine having Curtain Lite Admin, we call it Curtain Policy Server)

Curtain Lite Client:
When administrators want to display watermark on screen in user's computers, Curtain Lite Client must be 
installed in those computers. 

Curtain Lite Admin:
Curtain Lite Admin is mainly for administrators to define Curtain control policies centrally. In general, only 
one Curtain Lite Admin is needed in a company.

P.S.  
- Curtain Lite Admin can be installed on physical machine or virtual machine (VM).
- For standalone computer, Curtain Lite Admin and Client can be installed on the same machine. It is 
recommended to enable password protection for Curtain Lite Admin for preventing users to change 
control policy.
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2 - Preparation before Installation
2.1 - High-level Installation Plan

Preparation:
Which computers do you want to display watermark on screen?

What kind of screen watermark do you want to apply (e.g. Full Screen Watermark or Application 

Screen Watermark)?
Duration of displaying screen watermark (e.g. always or specific time slot)?

Which server will act as Curtain Policy server (i.e. Curtain Lite Admin will be installed on that 

server)?
Do you want to integrate Curtain MonGuard with Active Directory (so that control policy can be 

granted to AD user/user group)?

High-level installation plan:
1. Install Curtain Lite Admin
2. Install Curtain Lite Client on user's workstations
3. Activate Curtain MonGuard (for Paid version)
4. Define format of screen watermark
5. Create and configure control policy groups in Curtain Lite Admin
6. Connect with Active Directory for collecting user information, if you prefer to grant control policy by 
user/user-group
7. Assign workstations/users to different policy groups
8. Done

Related FAQs:
FAQ00318 - What are the basic components of Curtain MonGuard?
FAQ00308 - How to activate Curtain MonGuard? 
FAQ00305 - How to define format of screen watermark?
FAQ00303 - How to grant control policy by user/user group?
FAQ00302 - How to configure Control Policy Group?

2.2 - System Requirements of Curtain MonGuard and Curtain LogTrace

System Requirements of Curtain Lite Admin and Client:
1.6 GHz or faster, 2-core; 2 GHz or greater recommended

2GB RAM (Recommended 8GB RAM)

2GB Hard Disk (in NTFS) for installation

TCP/IP network

TCP Port 24821 and 24822 are opened for communication (Note: if firewall exists in the network, 

please make sure these two communication ports are not disabled)
For 64-bit OS, MSXML 4 or 6 is required (It can be download from Microsoft website)

P.S.: Curtain Lite program includes features of Curtain MonGuard and Curtain LogTrace
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Operating System 32-bit 64-bit
XP Supported Not Supported
Win Server 2003 Supported Not Supported
Win Server 2003 R2 Supported Not Supported
Vista Supported Not Supported
Win Server 2008 Supported Must have SP2 installed
Win Server 2008 R2 Supported Must have SP1 & KB3033929 installed
Win 7 Supported Must have SP1 & KB3033929 installed
Win 8 Supported Supported
Win 8.1 Supported Supported
Win Server 2012 \ Supported
Win Server 2012 R2 \ Supported
Win 10 Supported Supported
Win Server 2016 \ Supported
Win Server 2019 \ Supported
Win 11 \ Supported
Win Server 2022 \ Supported

2.3 - Open Port 24821 and 24822 for Curtain Lite Admin

If Windows Firewall is enabled, please open port 24821 for Curtain Lite Admin and Curtain Lite Client.

For Windows 2008/2012/2016/2019/2022/Vista/Win 7/Win 8/Win 10/Win 11, please add the rules for 
Curtain Lite Admin as below:

inbound rule of 24821 port of TCP

inbound rule of 24821 port of UDP

outbound rule of 24822 port of TCP

outbound rule of 24822 port of UDP

For Windows 2003 and XP, set the port exception as below:
24821 port of TCP

24821 port of UDP

24822 port of TCP

24822 port of UDP

For Windows 2008/2012/2016/2019/2022/Vista/Win 7/Win 8/Win 10/Win 11, please add the rules for 
Curtain Lite Client as below:

outbound rules of 24821 port of TCP

outbound rules of 24821 port of UDP

inbound rules of 24822 port of TCP

inbound rules of 24822 port of UDP

For Windows 2003 and XP, set the port exception as below:
24821 port of TCP

24821 port of UDP

24822 port of TCP

24822 port of UDP

Steps to add rules for Windows 2008/2012/2016/2019/2022/Vista/Win 7/Win 8/Win 10/Win 11:
1. Select "My Computer" and right click to select "Manage"
Then, Server Manager will be shown.
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2. In Server Manager, select "Inbound Rules" as below picture and right click to select "New Rule..."

3. New Inbound Rule Wizard is shown as below, choose Port and click Next.
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4. This rule applies to TCP and enter "24821" in Specific local ports, and click Next.
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5. Select "Allow the connection", and click Next.
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6. Check all as shown below (i.e. "Domain", "Private", and "Public") and click Next.
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7. Enter "curtain" for the name of this rule, and click Finish.
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8. A new inbound rule named "curtain" is created successfully.

Please according to the above steps, to add more rules for:
inbound rule of 24821 port of UDP

outbound rule of 24822 port of TCP

outbound rule of 24822 port of UDP

outbound rules of 24821 port of TCP (Curtain Lite Client)

outbound rules of 24821 port of UDP  (Curtain Lite Client)

inbound rules of 24822 port of TCP  (Curtain Lite Client)

inbound rules of 24822 port of UDP (Curtain Lite Client)

P.S.  To create outbound rule, select "Outbound Rules" and right click to select "New Rule..."
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Steps to set Port Exception for Windows 2003 and XP:
1. Click "Add Port..." button in Control Panel > Windows Firewall > Exceptions 

2. Enter 24821 and select TCP. Then, enter a name for this exception and click OK.

 

Please according to the above steps, to add more exceptions for:
24821 port of UDP

24822 port of TCP

24822 port of UDP

24821 port of TCP (Curtain Lite Client)

24821 port of UDP  (Curtain Lite Client)

24822 port of TCP  (Curtain Lite Client)

24822 port of UDP (Curtain Lite Client)
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3 - Installation

3.1 - Install Curtain Lite Admin

After you decide which server acts as Curtain Policy server, you should install Curtain Lite Admin on that 
server.  Here are the steps.

Steps to install Curtain Lite Admin:
1. Copy appropriate Curtain server setup package (e.g. CurtainLiteAdmin_Win32(327400).zip or CurtainLite
Admin_X64(327400).zip) to local hard-disk of the server.

2. Unzip the setup package.

3. Run Curtain server setup program. Make sure that you login Windows with administrator right.
Then, you will be asked to select Language for the installation.

4. Select a language and click OK.
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5. Read License Agreement.  If you accept the agreement, select "I accept the terms of the license 
agreement" and click Next to continue.
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Then, you will be asked to select Curtain components to install.

6. By default, "Curtain Admin" is selected. Click Next to continue.

7. Select Destination Folder for the installation, and click Next to continue.

8. Click Install to start the installation.

9. Please reboot the server after the installation.
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3.2 - Install Curtain Lite Client

If you want to display watermark on screen in a user's workstation, you should install Curtain Lite Client on 
that.  Here are the steps.

Steps to install Curtain Lite Client:
1. Copy appropriate Curtain Lite client setup package (e.g. CurtainLiteClient_Win32(327400).zip or 
CurtainLiteClient_X64(327400).zip) to local hard-disk of user's workstation.

2. Unzip the setup package.

3. Run Curtain Lite client setup program. Make sure that you login Windows with administrator right.
Then, you will be asked to select Language for the installation.

4. Select a language and click OK.
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5. Read License Agreement.  If you accept the agreement, select "I accept the terms of the license 
agreement" and click Next to continue.
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Then, the setup program will check your system environment for the installation, click Next to continue.
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6. Enter hostname or IP Address of Curtain Lite Admin (Please make sure that it is entered correctly), and 
click Next to continue.

7. Select Destination Folder for the installation, and click Next to continue.

8. Click Install to start the installation.

9. Reboot the workstation after installing Curtain Lite Client.

P.S.  There is no user interface for Curtain Lite Client. You can find it in Windows control panel.
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4 - Product Activation
4.1 - Activate Curtain MonGuard

Curtain MonGuard is a shareware. You can download and use the software for free on a trial basis or 
commercial use. If you want to display [username] and [IP address] in screen watermark and some 
advanced features, you need to activate the software to paid version.

Steps to activate Curtain MonGuard:
1. In Curtain Lite Admin, select "Help > About Curtain Lite Administrator". Then, the following dialog will 
appear.

2. Click "Activate Curtain Lite", you will be asked to do the activation.

3. Click Yes to start Product Activation (or click No to skip the Activation).
If it is the first time you activate the software, you will be asked to enter a 25-character Product 

Key. 
If it is the Annual Product Reactivation, please go to Step 5 to continue.
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4. Enter Product Key (which is case sensitive) and company information, and click OK to continue.  Then, the 
following dialog will appear.

5. Click "Generate Request file..." button to generate Activation Request File, and send this file to 
Coworkshop (registration@coworkshop.com). After receiving your activation request, Coworkshop will 
send Confirmation Code file back to you.

6. After receiving Confirmation Code file from Coworkshop, click "Import Confirm File..." button and select 
the file.  After you click OK, the following message box will appear.

Congratulations! Curtain MonGuard has been activated successfully.
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5 - Configurations
5.1 - Define format of Screen Watermark

Administrators can define the way how screen watermark display in user's workstations, such as content of 
watermark, font size, transparency, and etc.  Please follow below steps to define the format.

Steps to define format of screen watermark:
1. In Curtain Lite Admin, select "File > Settings".
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2. In Screen Watermark tab, select "Enable Text Watermark" 

Color: Color of screen watermark

Font Size: Font size of screen watermark

Font: Font of screen watermark

Font Style: Text Style of screen watermark (Hollow or Solid)

Display Mode: Display mode of screen watermark (Tile or Center). When Tile is selected, the 

whole screen will be filled with screen watermark. If Center is selected, only one screen watermark 
will be shown in the center of screen.
Slope Angle: Slope angle of displaying screen watermark

Refresh Interval: Time interval for refreshing content of screen watermark

Horizontal Space:  In Tile display mode, horizontal space of each screen watermark

Vertical Space: In Tile display mode, vertical space of each screen watermark

Transparency: Transparency for screen watermark

Text Content: Define content of screen watermark here

Text Parameter : Display [DateTime], [Hostname], [IP] and [UserName] in screen watermark

[DateTime]: Date and timeo
[Hostname]: Computer nameo
[IP]: IP address (this parameter is ONLY available in paid version)o
[UserName]: Windows login username (this parameter is ONLY available in paid version)o
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3. Click OK button when finish the setup.
4. Done.

Here is an example.
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5.2 - Create Control Policy Group

Administrators can create many Control Policy Groups in Curtain MonGuard for different 
workstations/users.  Here is an example of Control Policy Groups for reference.
- Default Policy: for general users, always display Full Screen Watermark
- Managers:  for senior management, only display Application Screen Watermark for MS Word, Excel, 
PowerPoint and Adobe Reader in office hours

Steps to create Control Policy Group:
1. In Curtain Lite Admin, select "File > New Policy" in the menu.  Then you will be asked to enter new Policy 
Name.

2. Enter new Policy Name and click OK to confirm.  
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5.3 - Configure Control Policy Group

Steps to configure Control Policy Group:
1. In Curtain Lite Admin, select a Policy Group and right-click to select "Properties".

Here is a summary of settings in a Policy Group. 

Screen Watermark tab
Enable Screen Watermark

Full Screen Watermarko
Application Screen Watermarko

Conditions

Always Enableo
Enable Wheno

Advanced Settings tab
Specify some advanced client settings (e.g. duration of keeping debug log)

We focus on Screen Watermark tab here. For other settings, please refer to other FAQs.

2. In Screen Watermark tab, select "Enable Screen Watermark":
- if you want to display Full Screen Watermark, select "Full Screen Watermark" and go to Step 5 to continue.
- if you want to display Application Screen Watermark, select "Application Screen Watermark".
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3. Click "Applications" button for enabling screen watermark for specific application(s).

4. Select application(s) which you want to display screen watermark.

5. Under Conditions:
- if you want to display screen watermark all the time, select "Always Enable" and click OK to save the 
settings.
- if you want to display screen watermark in specific time slot, select "Enable When" and click "Add" button 
for adding time slot (multiple time slots are supported).
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6. Enter time slot information and click OK.

5.4 - Set Default Policy

If it is the first time to launch Curtain Lite Admin (after the installation), "Default Policy" is set as default 
policy. If a new Control Policy Group is set as default policy, all newly installed Curtain Lite Clients will fall 
into that Policy Group.  A green tick indicates which Policy Group is default policy.  

There are two built-in Control Policy Groups. 
- Default Policy
- Wait for Assignment

When Curtain Lite Clients have been installed in user's workstations, they will connect to Curtain Lite Admin 
and apply default policy.
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Steps to set a Control Policy Group to default policy:
1. In Curtain Lite Admin, select a Control Policy Group and right-click.  Then a menu will be shown.

2. Select "Set as default policy"

3. Done

5.5 - Grant control policy by user/user group

Control policy of Curtain MonGurard can be applied to computer or user/user group.  If you prefer to grant 
control policy by AD user/user group, you need to connect with AD for importing user information to 
Curtain Lite Admin. When the first time Curtain Lite Admin gets a user information, the system will use 
default control policy for controlling that user/user group.  Administrator needs to assign the user/user 
group to appropriate control policy group manually.

To grant control policy by user/user group, please follow steps stated below to enable "Assignment of 
User" in Curtain Lite Admin.

Steps for enabling "Assignment of User" in Curtain Lite Admin:
1. Launch Curtain Lite Admin, open File -> Settings -> Assignment of Security Policy.

2. Choose "Assignment of User", and click "OK" button. 
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Then "User And Group" will be shown in Curtain Lite Admin.

3. Done. 

Steps for importing users and user groups from AD domain:
1. Launch Curtain Lite Admin, open File -> Settings -> LDAP.

2. Check "Enable LDAP" button.

3. Enter LDAP server address, DNS or IP address on "LDAP Server Address".

4. "LDAP Server Port", default port is 389.

5. Recommend to enable "Use Secure LDAP Connection", it means to use secure LDAP connection to AD 
(default is disable).

6. Enter user name on "LDAP Username"  to connect LDAP server.

7. Enter password on "LDAP Password".

8. "LDAP Search Base", enter the root of user or group , should enter CN, OU and DC .
for search the whole domain, enter "dc=domain name,dc=domain suffix" (e.g. 

"dc=test,dc=com")
for search the whole group, enter "ou=organizational unit name,dc=domain name,dc=domain 

suffix" (e.g. "ou=it,dc=test,dc=com")
for search single user, enter "cn=username,ou=organizational unit name,dc=domain 

name,dc=domain suffix" (e.g. "cn=tester,ou=it,dc=test,dc=com")

9. "LDAP Information Caching", for setup caching information of AD (default is 15 minutes).
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10. While setting is finished, click "Test connection" button to see whether connect to AD successfully or 
not.
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11. If AD user/user group is imported to Curtain Lite Admin successfully, they will be shown under "User 
And Group" in Curtain Lite Admin as below.

12. Done.

Steps to assign users/user groups to different Control Policy Groups: 
1. In Curtain Lite Admin, select User/Group in left panel. Then, Users/Groups will be listed out in the right 
panel. 

2. Select users/groups (press Ctrl button for multiple selection).
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3. Right click and select "Change Policy" to assign users/groups to appropriate Control Policy Group.

4. Repeat Step 2-3 for assigning other users/groups to appropriate policy groups. 

5. Done.

5.6 - Assign workstations/users to Control Policy Group

Steps to assign workstations to different Control Policy Groups:
1. In Curtain Lite Admin, select Online/Offline in left panel.  Then, workstations will be listed out in the right 
panel.

2. Select workstations (press Ctrl button for multiple selection)
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3. Drag and Drop selected workstations to appropriate Control Policy Group

4. Repeat Step 2-3 for assigning other workstations to appropriate policy groups.

5. Done

Steps to assign users to different Control Policy Groups:
1. In Curtain Lite Admin, select User/Group in left panel. Then, Users/Groups will be listed out in the right 
panel. 

2. Select users/groups (press Ctrl button for multiple selection).
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3. Right click selected users/groups, choose "Change Policy" and assign users to appropriate Control Policy 
Group.

4. Repeat Step 2-3 for assigning other users/groups to appropriate policy groups. 

5. Done.
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6 - Other Features
6.1 - Password protection for uninstalling Curtain Lite Client

By default, users do not need to enter password for uninstalling Curtain Lite Client.  Administrators can 
enable Password Protection for removing Curtain Lite Client to enhance the security. 

Steps to enable Password Protection for uninstalling Curtain Lite Client:
1. In Curtain Lite Admin, select "File > Settings".

2. In Password Management tab, check "Password Protection" of Uninstall Password Under Client Password 
Management as below. 

3. Enter  "OK" to confirm.
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Steps to Uninstall Curtain Lite Client with password protection :
1. In Curtain Lite Admin, select Online/Offline in left panel.  Then, workstations will be listed out in the right 
panel.

2. Select workstations and right click to choose "Generate Client Uninstall Password" 
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Then unique password will be generated for each client. These passwords are used for uninstalling Curtain 
Lite Client in specific workstation.

3. In workstation (e.g. MSEDGEWIN10), uninstall Curtain Lite Client in Windows Control Panel.
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4. Enter the uninstall password and Click "OK" to proceed.

P.S.  Each workstation has unique password for uninstalling Curtain Lite Client.

6.2 - Set login password for Curtain Lite Admin

By default, users do not need to enter password for launching Curtain Lite Admin.  Administrators can 
enable password protection to enhance the security. 

Steps to enable login password for Curtain Lite Admin:
1. In Curtain Lite Admin, select "File > Settings".
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2. In Password Management tab, check "Password Protection" under Administrator Password Management 
as below.  If it is the first time to set password for Curtain Lite Admin, a dialog box will be shown for 
entering new password.  Otherwise, the last password will be used.
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3. Enter password and click "OK" to confirm.

4. Done.  Next time administrators have to enter correct password when they open Curtain Lite Admin.

P.S.
1. The password management function can only be used after activation.
2. For Administrator Login ID, please refer to FAQ00310.
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